problem running Version 17.0

For Raspberry Pi specific issues .. more general issues will appear in UNIX and Linux

problem running Version 17.0

Postby ray on Mon Feb 04, 2019 5:07 pm

Hi

I have Dyalog 16 on my RPi ZERO, and today tried to upgrade to 17.

The upgrade to (17.0.35466) appears to be OK and I can run it with
Code: Select all
/opt/mdyalog/17.0/32/unicode/mapl

and I see 17.0.35466 start up.

However, starting up Dyalog via the command
Code: Select all
dyalog

still starts up version 16.0.35315

How can I get the command "dyalog" to run 17.0?

Thanks
Ray
Ray Cannon
Please excuse any smelling pisstakes.
User avatar
ray
 
Posts: 146
Joined: Wed Feb 24, 2010 12:24 am
Location: Blackwater, Camberley. UK

Re: problem running Version 17.0

Postby AndyS|Dyalog on Tue Feb 05, 2019 11:46 am

Hi Ray

What command(s) did you run to update from 16.0 to 17.0 ?
Had you altered /usr/bin/dyalog at all ?
User avatar
AndyS|Dyalog
 
Posts: 198
Joined: Tue May 12, 2009 6:06 pm

Re: problem running Version 17.0

Postby ray on Tue Feb 05, 2019 11:58 am

Hi Andy,
I have now (just before you replied) got round the problem.

I have modified the line in /etc/alternatives/dyalog
Code: Select all
export DYALOG=/opt/mdyalog/16.0/32/unicode

to read
Code: Select all
export DYALOG=/opt/mdyalog/17.0/32/unicode

and this seems to have done the trick.

I assume part of the upgrade to 17.0 on my Pi ZERO failed. There were some error messages relating to Miserver 4.1 displayed during the
Code: Select all
sudo apt-get dist-upgrade


I have NOT altered /usr/bin/dyalog.

Do you want any more information, and do I need to do any thing else?

Thanks
Ray
Ray Cannon
Please excuse any smelling pisstakes.
User avatar
ray
 
Posts: 146
Joined: Wed Feb 24, 2010 12:24 am
Location: Blackwater, Camberley. UK

Re: problem running Version 17.0

Postby AndyS|Dyalog on Fri Feb 08, 2019 4:04 pm

Ray and I have corresponded further about this. We're not entirely sure what happened, but I have learned that you should never edit /usr/bin/dyalog on Linux/Pi. Linux has a system which allows you to select which of several different versions of selected files you want to use - the update-alternatives system.

If on Linux/Pi you wish to alter which version /usr/bin/dyalog points to, simply run
      sudo update-alternatives --config dyalog
and select the version that you wish to run.

It is never a good idea to edit the mapl script in the Dyalog installation directory .. we recommend either taking a copy of mapl editing that, or writing your own script and pointing to $DYALOG/mapl .. actually, it's never a good idea to edit any file in any Dyalog installation .. we might overwrite it in the next patch (and this is likely to be true of Dyalog on Windows in the not too distant future too).
User avatar
AndyS|Dyalog
 
Posts: 198
Joined: Tue May 12, 2009 6:06 pm


Return to Raspberry Pi

Who is online

Users browsing this forum: No registered users and 0 guests