SessionTimeout setting

MiServer is Dyalog's APL-based web development framework

SessionTimeout setting

Postby Gantois on Sun Apr 02, 2017 12:20 pm

Hi Friends,

I am making timeout tests on my miserver app. For this purpose, I'm trying to change the default SessionTimeOut to 1 minute in \Config\Server.xml seting as following:

<SessionTimeout>1</SessionTimeout>

It's not working. My miserver version is: v2.1 and the time remain 10 minutes

Could someone help me?
Tanks,
Marco
Gantois
 
Posts: 70
Joined: Thu Apr 17, 2014 9:44 am

Re: SessionTimeout setting

Postby Brian|Dyalog on Fri Apr 07, 2017 3:13 pm

Hi Marco,

There isn't a <SessionTimeout> setting in MiServer 2, it's something we introduced with MiServer 3.0. To change it in MiServer 2, edit the SimpleSessions.dyalog file and change the line that reads:

:Field Public TimeOut←10 ⍝ Minutes

to whatever value you want.

I hope this helps!
/Brian
User avatar
Brian|Dyalog
 
Posts: 86
Joined: Thu Nov 26, 2009 4:02 pm
Location: West Henrietta, NY

Re: SessionTimeout setting

Postby Gantois on Tue Apr 11, 2017 11:37 am

Thanks Brian
Att, Marco
Gantois
 
Posts: 70
Joined: Thu Apr 17, 2014 9:44 am


Return to MiServer

Who is online

Users browsing this forum: No registered users and 1 guest