Windows 8, Dyalog APL v13.2, and input methods

Installing APL, Sorting out Fonts, Keyboards, etc.

Windows 8, Dyalog APL v13.2, and input methods

Postby dennisdjensen on Wed May 15, 2013 3:52 pm

Greetings!

I recently installed a copy of Windows 8 64bit on my Thinkpad X220 laptop in order to install Dyalog APL 13.2 for educational use. Everything is working fine, but as far as keyboard and input methods go, I have come across a confusing phenomenon about the installation/configuration. I am going to describe it here, because others may have experienced the same, and they can avoid the confusement I had momentarily.

I have installed both Danish and English languages with Danish and US English keyboard layouts, because I am from Denmark, but I always use US English keyboard layout for programming, and when I am chatting or writing in english fora such as this.

After I installed Dyalog APL I had 2 additional keyboard layouts, one for each language: Dyalog APL IME (en-US) and Dyalog APL IME (da-DK). No problem. Both of them works, but it turns out they have been switched. The IME en-US variant uses a danish keyboard layout, and the IME da-DK variant uses a US english keyboard layout, or input method - I am not sure. Odd. I then consulted the excellent documentation for Dyalog APL, and from inside Dyalog APL picked Options -> Configure -> Unicode input. I clicked Configure layout... for each of the 2 IME (en-US and da-DK) in the listbox, and sure enough, they had for some reason been exchanged. I configured them to match the description, and restarted Dyalog.

This is where confusement begins, because it didn't do any difference at all. Consequently I am now using Dyalog IME (da-DK) when I am really using what should have been Dyalog IME (en-US). No problem, but it may have confused others who have multiple input methods and languages installed on their Windows 8 system like I have. The configuration is a bit different from Windows 7, but otherwise it's the same, perhaps even easier to manage.

If you experience a similar issue, try a different input method, either from Windows 8 or from inside Dyalog APL or both.

The input methods and Unicode works flawlessly otherwise. I was able to copy, paste, and email some code to my brother, in an email browser client, which he was perfectly able to read on his Mac Pro laptop, as well as copy, and paste into TextEdit on Mac OS X. I am very pleased.

Details of installation information:

Lenovo Thinkpad X220, Intel Core i7-2620M, 64bit, 2.7Mhz, 8GB RAM, about 320GB Storage Disk - Windows 8 64bit

Version: 13.2.17633.0 32 Unicode
Created: May 1 2013 at 18:32:33
Build ID: 5e6e211d
Serial Number: 501661

--
Dennis Decker Jensen
dennisdjensen
 
Posts: 3
Joined: Sat May 11, 2013 3:17 pm

Re: Windows 8, Dyalog APL v13.2, and input methods

Postby Vince|Dyalog on Thu May 16, 2013 12:22 pm

Hi Dennis,

That's quite strange!

Could you start the registry editor on your Windows 8 PC and export the following key please?

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layouts

Please place the exported .reg file in a zip file and email it to support@dyalog.com

Regards,

Vince
Vince|Dyalog
 
Posts: 307
Joined: Wed Oct 01, 2008 9:39 am

Re: Windows 8, Dyalog APL v13.2, and input methods

Postby dennisdjensen on Thu May 16, 2013 5:01 pm

Hi Vince!

Vince|Dyalog wrote:That's quite strange!

Could you start the registry editor on your Windows 8 PC and export the following key please?

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layouts

Please place the exported .reg file in a zip file and email it to support@dyalog.com


Strange indeed! I just sent an email as requested (using Window+R with regedit to export keyboard translations).

Regards, Dennis Decker Jensen
dennisdjensen
 
Posts: 3
Joined: Sat May 11, 2013 3:17 pm

Re: Windows 8, Dyalog APL v13.2, and input methods

Postby dennisdjensen on Fri May 17, 2013 3:52 pm

All right, since this is primarily a labeling problem, I was able to fix it by exchanging the labels of the 2 keyboard layouts, and reboot the machine to fix this minor issue.

Thank you, Vince!
dennisdjensen
 
Posts: 3
Joined: Sat May 11, 2013 3:17 pm


Return to Installation

Who is online

Users browsing this forum: No registered users and 0 guests