Interpreter exited with code 132 on OSX 10.11 (El Capitan)

A forum for issues on macOS; the UNIX and Linux forums may have relevent posts

Interpreter exited with code 132 on OSX 10.11 (El Capitan)

Postby mhpcto on Wed Oct 30, 2019 2:45 am

Downloaded Dyalog 17.1 and get the error in the subject line.
Does this imply that 17.1 will not run on 10.11? If that's the case, what is the latest version of Dyalog that runs on El Capitan?
mhpcto
 
Posts: 5
Joined: Tue Sep 18, 2018 5:36 pm

Re: Interpreter exited with code 132 on OSX 10.11 (El Capita

Postby Vince|Dyalog on Wed Oct 30, 2019 9:46 am

Hi mhpcto,

I will send you an email from Dyalog Support and will ask you to do some experiments.

Regards,

Vince
Vince|Dyalog
 
Posts: 311
Joined: Wed Oct 01, 2008 9:39 am

Re: Interpreter exited with code 132 on OSX 10.11 (El Capita

Postby mhpcto on Wed Oct 30, 2019 5:17 pm

Thanx. I sent you the error messages and backtrace.
mhpcto
 
Posts: 5
Joined: Tue Sep 18, 2018 5:36 pm

Re: Interpreter exited with code 132 on OSX 10.11 (El Capita

Postby Vince|Dyalog on Thu Nov 14, 2019 3:07 pm

I have had a discussion with mhpcto and he has found that dyalog is crashing with an illegal instruction.

In a terminal window:

cd /Applications/Dyalog-17.1.app/Contents/Resources/Dyalog/

./mapl

gives line 111: 97940 Illegal instruction: 4 $DYALOG/dyalog $OPTS

./dyalog

gives

Illegal instruction: 4

This is because our Dyalog for Mac builds have a requirement for SSE 4.1 CPU instructions. Macs introduced in 2010 or later should be OK for that. Our current platforms webpage is here: https://www.dyalog.com/dyalog/current-platforms.htm

Regards,

Vince
Vince|Dyalog
 
Posts: 311
Joined: Wed Oct 01, 2008 9:39 am


Return to macOS

Who is online

Users browsing this forum: No registered users and 1 guest