Install DYALOG and Ride under BULLSEYE

For Raspberry Pi specific issues .. more general issues will appear in UNIX and Linux

Install DYALOG and Ride under BULLSEYE

Postby bilekflo on Fri Jan 14, 2022 11:33 am

Dear all,


I tried to install Dyalog on the new version of Rasperry OS (BULLSEYE).

I followed the instructions given but fail at the installation of the packges:

sudo apt-get install dyalog-unicode
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
E: Unable to locate package dyalog-unicode

However, the installation of the interpreter alone (dyalog-unicode-180) works.

I don't know why, but it seems there is an issue when using bullseye repository in the dyalog.list file.
Replacing it with buster it works and dyalog-unicode installs the interpreter and ride.

After installation, I cannot start Ride 4.3:

pi@raspberrypi:~ $ride-4.3
../../sandbox/linux/seccomp-bpf-helpers/sigsys_handlers.cc:**CRASHING**:seccomp-bpf failure in syscall 0403
../../sandbox/linux/seccomp-bpf-helpers/sigsys_handlers.cc:**CRASHING**:seccomp-bpf failure in syscall 0403
../../sandbox/linux/seccomp-bpf-helpers/sigsys_handlers.cc:**CRASHING**:seccomp-bpf failure in syscall 0403
../../sandbox/linux/seccomp-bpf-helpers/sigsys_handlers.cc:**CRASHING**:seccomp-bpf failure in syscall 0403
../../sandbox/linux/seccomp-bpf-helpers/sigsys_handlers.cc:**CRASHING**:seccomp-bpf failure in syscall 0403
../../sandbox/linux/seccomp-bpf-helpers/sigsys_handlers.cc:**CRASHING**:seccomp-bpf failure in syscall 0403
[4558:0114/115729.681897:FATAL:gpu_data_manager_impl_private.cc(894)] The display compositor is frequently crashing. Goodbye.
Trace/breakpoint trap

Any hints would be appreciated.

Regards Florian
bilekflo
 
Posts: 12
Joined: Wed Mar 12, 2014 10:07 pm

Re: Install DYALOG and Ride under BULLSEYE

Postby meijerjo on Fri Jan 14, 2022 8:25 pm

Can you try launching RIDE this way?

/opt/ride-4.3/launcher --no-sandbox

Does that work?
John
meijerjo
 
Posts: 5
Joined: Thu Jan 06, 2022 4:29 pm

Re: Install DYALOG and Ride under BULLSEYE

Postby meijerjo on Sun Jan 16, 2022 8:16 pm

This should work too. Maybe less insecure?

/opt/ride-4.3/launcher --disable-features=VizDisplayCompositor
meijerjo
 
Posts: 5
Joined: Thu Jan 06, 2022 4:29 pm

Re: Install DYALOG and Ride under BULLSEYE

Postby bilekflo on Mon Jan 17, 2022 8:07 am

Hi meijerjo,

The first solution is working:

pi@raspberrypi:/opt/ride-4.3 $ ./launcher --no-sandbox <- This is OK.

The second shows errors but starts RIDE as well:

pi@raspberrypi:/opt/ride-4.3 $ /opt/ride-4.3/launcher --disable-features=VizDisplayCompositor

../../sandbox/linux/seccomp-bpf-helpers/sigsys_handlers.cc:**CRASHING**:seccomp-bpf failure in syscall 0403
../../sandbox/linux/seccomp-bpf-helpers/sigsys_handlers.cc:**CRASHING**:seccomp-bpf failure in syscall 0403
../../sandbox/linux/seccomp-bpf-helpers/sigsys_handlers.cc:**CRASHING**:seccomp-bpf failure in syscall 0403

Should I register a bug at Ride GIT?

BR Florian
bilekflo
 
Posts: 12
Joined: Wed Mar 12, 2014 10:07 pm

Re: Install DYALOG and Ride under BULLSEYE

Postby meijerjo on Mon Jan 17, 2022 11:41 pm

Interesting I get no error with the second command, but I am running Ubuntu Server on my RPi4, not Raspbian so your error might be distro specific.

I'm no expert but I think the no-sandbox command might be less secure, so I'd use the latter if it works apart from the warnings.
John
meijerjo
 
Posts: 5
Joined: Thu Jan 06, 2022 4:29 pm

Re: Install DYALOG and Ride under BULLSEYE

Postby bilekflo on Tue Jan 18, 2022 2:27 pm

I think that this error is distribution specific.
Further I checked now in the RIDE Git.
The problem is already known (https://github.com/Dyalog/ride/issues/796)

There the workaround is: ride --disable-seccomp-filter-sandbox

Florian
bilekflo
 
Posts: 12
Joined: Wed Mar 12, 2014 10:07 pm

Re: Install DYALOG and Ride under BULLSEYE

Postby meijerjo on Tue Jan 18, 2022 3:28 pm

Thanks for that information.
That flag works for me too, with no errors/warnings, under Ubuntu.
John
meijerjo
 
Posts: 5
Joined: Thu Jan 06, 2022 4:29 pm

Re: Install DYALOG and Ride under BULLSEYE

Postby AndyS|Dyalog on Tue Jan 18, 2022 4:41 pm

I think the original problem was of my making .. I added bullseye to the list of supported Raspberry Pi codenames when I uploaded the most recent set of 18.0 images for the Pi - and completely forgot about both RIDE and the dyalog-unicode images.

I have (I believe) added bullseye to the list of supported codenames for both these packages, and at the same time I've added a signature to all three images.

Please let me know how you get on with these !
User avatar
AndyS|Dyalog
 
Posts: 250
Joined: Tue May 12, 2009 6:06 pm

Re: Install DYALOG and Ride under BULLSEYE

Postby bilekflo on Wed Jan 19, 2022 8:05 am

I did remove interpreter and ride. Then I changed the dyalog.list file frombuster to bullseye.

Installation of dyalog-unicode works now correctly.

Thanks Andy.

However the start of ride still fails due to the problem I mentioned earlier in my previous post.

BR Florian
bilekflo
 
Posts: 12
Joined: Wed Mar 12, 2014 10:07 pm

Re: Install DYALOG and Ride under BULLSEYE

Postby AndyS|Dyalog on Thu Jan 20, 2022 4:37 pm

It looks like RIDE 4.3 will not run on bullseye.

We have therefore added the most recent pre-release of RIDE 4.4 to the Pi repos for bullseye, and we've updated the dyalog-unicode package to point to this.

So on buster and earlier you'll get 18.0 and RIDE 4.3, and on bullseye and later you'll get 18.0 and RIDE 4.4.

Jumping the gun slightly with RIDE 4.4, but it's due for release in the next few weeks, and is stable.
User avatar
AndyS|Dyalog
 
Posts: 250
Joined: Tue May 12, 2009 6:06 pm

Next

Return to Raspberry Pi

Who is online

Users browsing this forum: No registered users and 1 guest