Tidying up the Pi repositories

For Raspberry Pi specific issues .. more general issues will appear in UNIX and Linux

Tidying up the Pi repositories

Postby AndyS|Dyalog on Wed Jun 23, 2021 10:21 am

We discovered that our Raspberry Pi repository contained errors which we have fixed.

The errors meant that it was possible to download any version of Dyalog APL to any version of Raspbian/Raspberry Pi OS using apt get.

Now:
18.0 onwards can/will only be downloaded to Raspberry Pi OS buster.
17.1, 17.0 and 16.0 can be downloaded to Raspberry Pi OS jessie onwards.

It was also possible to download 18.1. This should not have been possible without specifying that you wanted to use the beta repository rather than the main repository. If you have 18.1 installed on your Pi then you should consider installing 18.0, using ]out and ]in to get any 18.1 workspaces into 18.0 and then uninstalling 18.1. If you need help with this or wish to discuss the matter further, please drop support@ an email.
User avatar
AndyS|Dyalog
 
Posts: 243
Joined: Tue May 12, 2009 6:06 pm

Return to Raspberry Pi

Who is online

Users browsing this forum: No registered users and 1 guest