rscproxy outdated?

APL-related discussions - a stream of APL consciousness.
Not sure where to start a discussion ? Here's the place to be
Forum rules
This forum is for discussing APL-related issues. If you think that the subject is off-topic, then the Chat forum is probably a better place for your thoughts !

rscproxy outdated?

Postby mhpcto on Wed Jun 24, 2020 4:35 pm

I just upgraded to V18 and tried to get the R interface up.

I have both R 4.0.2 and 3.6.3 installed (Windows 10)

Trying to install rscproxy via the download link in the docs results in:

Warning in install.packages :
package ‘https://github.com/Dyalog/rscproxy/releases/download/2.0-5-dyalog3/rscproxy_2.0-5.zip’ is not available (for R version 3.6.3)

Can't find any info on what the last supported version of R would be.
mhpcto
 
Posts: 7
Joined: Tue Sep 18, 2018 5:36 pm

Re: rscproxy outdated?

Postby Vince|Dyalog on Thu Jun 25, 2020 10:07 am

Hi mhpcto,

I have had a crash using R 4.0.2 with our rscproxy and Dyalog, so please use R 3.6.3 until we figure out what is happening with R 4.0.2.

I have done the following:

1) Start the R GUI with a right click and "Run as administrator"

R version 3.6.3 (2020-02-29) -- "Holding the Windsock"
Copyright (C) 2020 The R Foundation for Statistical Computing
Platform: x86_64-w64-mingw32/x64 (64-bit)


2) This is the install.packages command to install our fork of rscproxy:
> install.packages("https://github.com/Dyalog/rscproxy/releases/download/2.0-5-dyalog3/rscproxy_2.0-5.zip")

inferring 'repos = NULL' from 'pkgs'
trying URL 'https://github.com/Dyalog/rscproxy/releases/download/2.0-5-dyalog3/rscproxy_2.0-5.zip'
Content type 'application/octet-stream' length 74804 bytes (73 KB)
downloaded 73 KB

package ‘rscproxy’ successfully unpacked and MD5 sums checked
>

3) Please add the R directory to your System Path:
C:\Program Files\R\R-3.6.3\bin\x64;


4) in Dyalog (I am using 18.0.35824 64-bit Unicode):

      )load rconnect
r←⎕new R
r.setdriver'rscproxyWin' 'C:\Program Files\R\R-3.6.3\'
r.init


Please contact us at Dyalog support if you have any problems or questions.

Regards,

Vince
Last edited by Vince|Dyalog on Mon Jul 20, 2020 9:06 am, edited 1 time in total.
Reason: typo of missing bin subdirectory corrected
Vince|Dyalog
 
Posts: 334
Joined: Wed Oct 01, 2008 9:39 am

Re: rscproxy outdated?

Postby Vince|Dyalog on Fri Jun 26, 2020 12:37 pm

Hi mhpcto,

I have obtained from Ron Murray, a consultant, a test build of rscproxy which fixes my crash with R 4.0.2.

I can email it to you if you are interested in trying it.

Regards,

Vince
Vince|Dyalog
 
Posts: 334
Joined: Wed Oct 01, 2008 9:39 am

Re: rscproxy outdated?

Postby mhpcto on Wed Jul 22, 2020 12:30 am

Vince,

I'd be happy to try it out.

As an aside, what is the root cause for having to use setdriver? Shouldn't adding the R location to PATH be sufficient? It has always worked for me in previous releases - this is the first time I had to use setdriver.

I have also found that there is different behavior when the R directory is added to the System path vs User. When using setdriver, r.init fails if the argument is not terminated with a trailing '\'.

An additional gotcha is that once setdriver has failed once, setdriver can not be called again or APL will crash when r.init is called after a subsequent successful setdriver.

This all seems a bit flaky and inconsistent. I shouldn't matter which PATH evar is used nor should a trailing '\' matter.

In any case, let me try the R 4.0 compatible version. I'll report back any issues.

Regards
mhpcto
 
Posts: 7
Joined: Tue Sep 18, 2018 5:36 pm

Re: rscproxy outdated?

Postby Vince|Dyalog on Thu Jul 23, 2020 2:18 pm

Hi Mhpcto,

I think setdriver is there to help in case we do not automatically find the R libraries based on what can see of the R directories and registry entries.

Thanks for the observations about user vs. system path and trailing slashes. I will try these out.

Regards,

Vince
Vince|Dyalog
 
Posts: 334
Joined: Wed Oct 01, 2008 9:39 am

Re: rscproxy outdated?

Postby Vince|Dyalog on Wed Jul 29, 2020 2:03 pm

For mhpcto and anyone else interested in our Dyalog rscproxy branch:

We have updated it with the fixes that I mentioned before in this thread.

https://github.com/Dyalog/rscproxy/rele ... -6-dyalog1
Vince|Dyalog
 
Posts: 334
Joined: Wed Oct 01, 2008 9:39 am


Return to APL Chat

Who is online

Users browsing this forum: No registered users and 1 guest