HTMLRenderer: in-page (a href="#...") links inert.

APL-related discussions - a stream of APL consciousness.
Not sure where to start a discussion ? Here's the place to be
Forum rules
This forum is for discussing APL-related issues. If you think that the subject is off-topic, then the Chat forum is probably a better place for your thoughts !

HTMLRenderer: in-page (a href="#...") links inert.

Postby ArrayMac227 on Sun Nov 05, 2017 2:25 pm

having an internal link in the .HTML ( <a href="#..." ) seems to cause no action. Bug? Feature? Configurable?

I ask this after realizing how daunting the prospect of including the full URL in the link is.
ArrayMac227
 
Posts: 40
Joined: Sat Sep 12, 2015 1:40 pm

Re: HTMLRenderer: in-page (a href="#...") links inert.

Postby norbertjurkiewicz84 on Mon Nov 06, 2017 12:34 am

Makes sure your HTMLRenderer HTTPRequest event callback is not rendering the call null.
User avatar
norbertjurkiewicz84
 
Posts: 48
Joined: Mon Nov 01, 2010 7:26 pm

Re: HTMLRenderer: in-page (a href="#...") links inert.

Postby ArrayMac227 on Mon Nov 06, 2017 2:07 pm

Testing with a full browser revealed that the URL is of the form:

"$path?$query#$location"

which means the '#location' becomes part of the query, thus invalid.

This is a problem, but how it affects the rendering of the raw HTML and that particular lack of link behaviour, not clear.

(note to self: further test local links...)
ArrayMac227
 
Posts: 40
Joined: Sat Sep 12, 2015 1:40 pm


Return to APL Chat

Who is online

Users browsing this forum: No registered users and 1 guest