Windows server 2019 and DAPL v18.0 character set problems

APL-related discussions - a stream of APL consciousness.
Not sure where to start a discussion ? Here's the place to be
Forum rules
This forum is for discussing APL-related issues. If you think that the subject is off-topic, then the Chat forum is probably a better place for your thoughts !

Windows server 2019 and DAPL v18.0 character set problems

Postby woody on Wed Jul 21, 2021 3:47 pm

Greetings,

I have a new Windows 2019 Server on AWS.
And installed the latest Dyalog 18.0 64 bit
And applied the current patch / update to APL.

I'm using Windows Remote Desktop (RDP) to connect to the AWS server.

For some reason ... the MAPPING between my keyboard keys and the characters generated are not right. I see two language options on the server taskbar ENG and Dyalog APL.
I can switch between them... and get either APL or ENG ...
But, when in APL, some of the normal non-APL characters get mismapped like ) (shift 0) and / (normal slash).

Has anyone else seen this type of keyboard character mis-mapping behavior ?

Sincere thanks,

//W

EXAMPLE MAPPING PROBLEMS
Code: Select all
Normal ENG      ENG APL
         :      Æ
         /      -
         )      =
         (      )
         =      ´
         \      '
         &      /
Woodley Butler
Automatonics, Inc.
"Find your head in the APL Cloud"
http://www.APLcloud.com
User avatar
woody
 
Posts: 141
Joined: Tue Dec 28, 2010 12:54 am
Location: Atlanta, Georgia USA

Re: Windows server 2019 and DAPL v18.0 character set problem

Postby AndyS|Dyalog on Fri Jul 23, 2021 9:25 am

Hi Woody

That looks like you've got a Danish keyboard selected rather than a US one .. there's a diagram of the different layouts on the dfns website.

Best thing is to go to Options->Configure->Unicode Input and see which Keyboard is selected .. I wonder if it's "Dyalog APL IME (da_DK)" rather than "Dyalog APL IME (en_US)".
User avatar
AndyS|Dyalog
 
Posts: 245
Joined: Tue May 12, 2009 6:06 pm

Re: Windows server 2019 and DAPL v18.0 character set problem

Postby woody on Sat Jul 24, 2021 2:19 am

Thanks for the reply!

I'm not sure where the incorrect keyboard key MAPPING is broken.
New Windows Server 2019
Fresh install of Dyalog 18.0 64 bit
I use Remote login.
I see the correct ENG and ENG-APL keyboard options on bottom right of Windows task bar.
and, here's what I see under DyalogAPL Configuration settings.

The issue seems to be happening only with the install of DyalogAPL v18.0.

NOTE: I have been installing Dyalog in a custom location:

c:\DyalogAPL

If that makes a difference ....

I have other servers with 14.1 and even 17.1 and do not see this issue (have used them for years with remote desktop connection).

I de-install v18.0 and reboot, then install 17.1 to see if the mapping issue still happens.

Thanks!

DyalogAPL_18_Configuration_US_Keyboard.jpg
Woodley Butler
Automatonics, Inc.
"Find your head in the APL Cloud"
http://www.APLcloud.com
User avatar
woody
 
Posts: 141
Joined: Tue Dec 28, 2010 12:54 am
Location: Atlanta, Georgia USA

Re: Windows server 2019 and DAPL v18.0 character set problem

Postby woody on Sat Jul 24, 2021 2:57 am

Well ...

DyalogAPL v17.1 64 has the same problem of key mapping as the new v18.0 on a new AWS Windows 2019 server.

I found a POST about 1 year old on a MS BLOG site that looks promising.
I'll try these actions:

I fixed my keyboard mapping issue by deleting Time & Language settings on both computers and deleting any "Preferred Languages" I was not using. In my case I'm using English (United States) on both computers. I deleted English (United Kingdom) on both [actually may have only been on one]. I restarted both computers and now all is well.


UPDATE:
I tried a different laptop with updated Windows 10... that does NOT have APL installed.
I used remote desktop to the new Windows 2019 server.
I opened APL 17.1 on that server.
I selected the ENG IME APL keyboard from task bar.
I was able to enter IOTA ⍳5 without issue.
I then tried to type the normal right Paren. above the ZERO.
SAME ISSUE. I got a = and not a ) from that keystroke.

The same behavior is seen by 2 of our team members.

UPDATE:
I then tried my PC again ... connecting to a different AWS Windows 2012-R2 server.
This is running Dyalog 14.1 64.
It has worked fine for years.
I selected the APL keyboard.
Then, entered both IOTA ⍳ and the normal Right Paren. above 0 )
Keyboard worked fine.


QUESTION:
How can I 100% remove DyalogAPL from a computer .. including all Registry Entries?



//W
Woodley Butler
Automatonics, Inc.
"Find your head in the APL Cloud"
http://www.APLcloud.com
User avatar
woody
 
Posts: 141
Joined: Tue Dec 28, 2010 12:54 am
Location: Atlanta, Georgia USA

Re: Windows server 2019 and DAPL v18.0 character set problem

Postby woody on Sun Jul 25, 2021 10:24 pm

ISSUE RESOLVED !

There seems to be a problem with the Remote keyboard key mapping when I install Dyalog in a new custom path C:\DyalogAPL

Rather than the typical default path.

I de-installed Dyalog.
And after restarting...
re-installed using typical path ...
and everything works fine.

NOTE: This is fine on a SERVER ..
but This typical standard path opens the potential of ONEDRIVE taking control over the folders and breaking APL.

FOOD FOR THOUGHT.

Cheers,

//W
Woodley Butler
Automatonics, Inc.
"Find your head in the APL Cloud"
http://www.APLcloud.com
User avatar
woody
 
Posts: 141
Joined: Tue Dec 28, 2010 12:54 am
Location: Atlanta, Georgia USA

Re: Windows server 2019 and DAPL v18.0 character set problem

Postby AndyS|Dyalog on Mon Jul 26, 2021 7:52 am

Hi Woody

Thanks for the update on the PD !

I've raised
019232: When installing remotely in a non-standard location the keyboard selection(s) appear to go awry
.. we'll see what we can do about this.
User avatar
AndyS|Dyalog
 
Posts: 245
Joined: Tue May 12, 2009 6:06 pm

Re: Windows server 2019 and DAPL v18.0 character set problem

Postby Vince|Dyalog on Fri Aug 27, 2021 1:13 pm

More about the Danish characters issue when using Remote Desktop into a Windows Server:

A UK customer gave us this procedure which is a work around, and it has been successfully used by another US customer:

• Start Dyalog session
• Options - Unicode Input - un-tick Activate selected keyboard
• Ok
• Make sure APL keyboard is off, (ctrl+shift) (** very important **)
• Close session
• Sign-out of your windows account
• Sign back in
• Open Dyalog Session
• Option - Unicode Input - tick Activate selected keyboard
• Ok
• Close session
• Start Dyalog session again
Vince|Dyalog
 
Posts: 356
Joined: Wed Oct 01, 2008 9:39 am


Return to APL Chat

Who is online

Users browsing this forum: No registered users and 1 guest