Keyboard setup on Linux

Using Dyalog under 'nixes

Re: Keyboard setup on Linux

Postby Geoff|Dyalog on Wed Nov 15, 2017 10:31 am

I don't have a Linux Mint to hand.

However, you want to look for a switch groups (or layouts) option rather than the level selector you have enabled.

On my KDE this is in the GUI as "Switching to another layout". I would expect Cinnamon to use exactly the same wording.

I would, also, suggest you enable the "Position of the compose key" - I, usually use the Menu key for this. It means you can type all sorts of things as well as all of the APL "overstrikes" that Unicode defines.

If this doesn't help: Say so and I will set up a Linux Mint VM.
Posts: 43
Joined: Wed May 13, 2009 12:36 pm

Re: Keyboard setup on Linux

Postby dhdurgee on Wed Nov 15, 2017 1:05 pm

You were correct. I disabled the "Key to choose 3rd level" and enabled my "Right Win key (while pressed)" in "Switching to another layout" and now I have access to the APL symbols.

Thank you for pointing out my error.

Posts: 14
Joined: Mon Feb 07, 2011 5:21 pm

Re: Keyboard setup on Linux

Postby yaemmanuelli on Fri May 21, 2021 2:27 pm


After upgrading Ubuntu to release 21.04 (hirsute), after the execution of, gnome catches the keystrokes from the Win key to show the list of applications, before Dyalog can receive it. I changed grp:win_switch to grp:caps_switch and it is a successful workaround. Changing to grp:rctrl_switch does not work.

i am using Dyalog 18.0.39712 Unicode launched with Ride in Gnome on Ubuntu 21.04

Yves-Antoine Emmanuelli
Yves-Antoine Emmanuelli
User avatar
Posts: 10
Joined: Sat Aug 01, 2020 6:29 pm
Location: Recloses, France


Return to UNIX and Linux

Who is online

Users browsing this forum: No registered users and 1 guest