How to prevent Dyalog 17.1 to change keyboard layout

Using Dyalog under 'nixes

How to prevent Dyalog 17.1 to change keyboard layout

Postby alexeyv on Sun Mar 08, 2020 6:16 pm

Dyalog 17.1 for Linux every time changes the layout at the startup(adding APL characters). It doesn't work very well all the time and messes the other layouts selected and their input mode.

Is there an option to disable the layout setup on a startup of the Dyalog for Linux? I would like to configure the way how I switch layouts and how enter characters by myself.

P.S. For example I don't want APL characters system wide and happy to enter them in RIDE only with RIDE's backtick prefix.
alexeyv
 
Posts: 56
Joined: Tue Nov 17, 2015 4:18 pm

Re: How to prevent Dyalog 17.1 to change keyboard layout

Postby Vince|Dyalog on Thu Mar 12, 2020 4:11 pm

Hi alexeyv,

How do you start Dyalog?

Have you tried the following, and does it help?

dyalog -nokbd

Regards,

Vince
Vince|Dyalog
 
Posts: 317
Joined: Wed Oct 01, 2008 9:39 am

Re: How to prevent Dyalog 17.1 to change keyboard layout

Postby alexeyv on Sat Mar 21, 2020 9:21 am

Sorry for late response.
-nokbd option helped me.
alexeyv
 
Posts: 56
Joined: Tue Nov 17, 2015 4:18 pm


Return to UNIX and Linux

Who is online

Users browsing this forum: No registered users and 1 guest