Accented characters

Using (or providing) components based on the "Win32" framework

Accented characters

Postby ksa on Sat Sep 21, 2019 9:04 am

Hi,
I am wondering why I can't enter accented characters like ü, é, etc. in a GUI text control?
I the "old days" (Classic) these animals were defined in the keyboard file, but not anymore.
Running v17.1 on Win10.
Thanks for any help.
...../Kim
ksa
 
Posts: 8
Joined: Thu Jul 18, 2019 7:02 pm

Re: Accented characters

Postby Morten|Dyalog on Sat Sep 21, 2019 2:51 pm

Hi Kim, I presume you are using a Danish keyboard and the Dyalog IME? I also noticed that "dead keys" stopped working recently but have not pursued it (sorry). Can you verify that you can work around the problem by using Windows Key + Space to select the base Danish keyboard rather than the IME?
User avatar
Morten|Dyalog
 
Posts: 355
Joined: Tue Sep 09, 2008 3:52 pm

Re: Accented characters

Postby ksa on Sat Sep 21, 2019 6:48 pm

Hi Morten,
Yes, I am using a (slightly modified) DK IME keyboard (more or less the same as SimCorp is/was using). Yes, the accented chars work if I manually switch to the standard DK keyboard. I noticed that when the GUI form has focus the APL keyboard is still in effect. Shouldn't the keyboard switch out of the APL and to the standard one when a GUI form gets focus? I do have the Windows setting "Let me use a different input method for each app window" enabled.
...../Kim
ksa
 
Posts: 8
Joined: Thu Jul 18, 2019 7:02 pm

Re: Accented characters

Postby Morten|Dyalog on Sat Sep 21, 2019 9:13 pm

I'm afraid that when a development interpreter starts GUI, that is part of the same application. Anyway, this is a bug - the Dyalog IME used to support the Danish dead keys, I am not sure exactly when/why this stopped working.
User avatar
Morten|Dyalog
 
Posts: 355
Joined: Tue Sep 09, 2008 3:52 pm

Re: Accented characters

Postby ksa on Sat Sep 21, 2019 9:22 pm

Perhaps the recent Windows update to version 1903 could be the culprit? Just a guess, triggered by you saying that it has stopped working "recently".
...../Kim
ksa
 
Posts: 8
Joined: Thu Jul 18, 2019 7:02 pm

Re: Accented characters

Postby JohnD|Dyalog on Tue Sep 24, 2019 8:11 am

OK, I can reproduce the problem. We'll have a fix soon.
User avatar
JohnD|Dyalog
 
Posts: 62
Joined: Wed Oct 01, 2008 9:35 am

Re: Accented characters

Postby JohnD|Dyalog on Thu Sep 26, 2019 11:47 am

OK, I've committed a fix for this. A new IME will be available, somewhere, in due course.
User avatar
JohnD|Dyalog
 
Posts: 62
Joined: Wed Oct 01, 2008 9:35 am


Return to Windows: GUI, COM/OLE/ActiveX

Who is online

Users browsing this forum: No registered users and 1 guest