V14.1 installation problem

Installing APL, Sorting out Fonts, Keyboards, etc.

V14.1 installation problem

Postby mario.sacco on Tue Jul 21, 2015 11:04 pm

I'm trying to install the 14.1 under Windows but it seems that it's already installed.
For sure I were wrong in unistalling previous versions(I have been installed also the Beta for 14.1).
Excuting the Setup.exe only the Dyalog APL IME appears among the installable SW, so that the Dyalog APL Interpreter cannot be checked.

Can I "force" in any way the installation? Any advice will be appreciated.
Thanks,
Mario
Mario Sacco
User avatar
mario.sacco
 
Posts: 9
Joined: Fri Oct 25, 2013 7:42 pm
Location: Roma - Italia

Re: V14.1 installation problem

Postby Vince|Dyalog on Wed Jul 22, 2015 8:10 am

Hi Mario,

Please email me at Dyalog Support and let me know the following:

What's the version number of the 14.1 Beta that you currently have installed?

Do you still have the installer files?

If so, please start cmd.exe with a right click and "Run as administrator"
cd to the directory where you unzipped the installer files.
Try this command:
msiexec -uninstall setup_32_unicode.msi

Does that now allow you to install the released 14.1?

Regards,

Vince
Vince|Dyalog
 
Posts: 300
Joined: Wed Oct 01, 2008 9:39 am

Re: V14.1 installation problem

Postby mario.sacco on Sun Aug 16, 2015 4:16 pm

Hi Vince,
my apologies for the delay in answering.

I unfortunately don't have the original files of the beta version and I don't remember the version because, in my many try, I uninstalled the Beta from my PC.

Mario
Mario Sacco
User avatar
mario.sacco
 
Posts: 9
Joined: Fri Oct 25, 2013 7:42 pm
Location: Roma - Italia

Re: V14.1 installation problem

Postby mario.sacco on Sat Sep 12, 2015 3:24 pm

Any advice?
Mario Sacco
User avatar
mario.sacco
 
Posts: 9
Joined: Fri Oct 25, 2013 7:42 pm
Location: Roma - Italia

Re: V14.1 installation problem

Postby Vince|Dyalog on Mon Sep 14, 2015 12:03 pm

Hi Mario,

I'm sorry that I hadn't realized you still had this problem.

I've sent you an email from Dyalog Support.

Regards,

Vince
Vince|Dyalog
 
Posts: 300
Joined: Wed Oct 01, 2008 9:39 am

Re: V14.1 installation problem

Postby Vince|Dyalog on Fri Sep 18, 2015 10:57 am

For everyone who reads this thread:

I've contacted Mario by email with this suggestion, and he found that it helps:

"Fix problems that programs cannot be installed or uninstalled"
https://support.microsoft.com/en-us/mats/program_install_and_uninstall?wa=wsignin1.0

Vince
Vince|Dyalog
 
Posts: 300
Joined: Wed Oct 01, 2008 9:39 am

Re: V14.1 installation problem

Postby mario.sacco on Mon Sep 28, 2015 7:12 am

Thanks Vince.

If could be useful, the specific case was:

in the "Programs/Uninstall a program" section of the Control Palnel Dyalog APL and its components did not appear

but

trying to install the new version of the interpreter the system blocks the installation as if the software is already installed.

The solution pointed by Vince (a Microsoft tool) helps you to clean *properly* the windows registry (this was the cause of the problem) making possible to reinstall the new interpreter version.
Why the Windows registry remains dirty even after correctly uninstalling the previous interpreter version ... is one of the mysteries of this operating system ... :-)
Mario Sacco
User avatar
mario.sacco
 
Posts: 9
Joined: Fri Oct 25, 2013 7:42 pm
Location: Roma - Italia


Return to Installation

Who is online

Users browsing this forum: No registered users and 1 guest