Dyalog IME and RIDE 4.1

Installing APL, Sorting out Fonts, Keyboards, etc.

Dyalog IME and RIDE 4.1

Postby ray on Mon Apr 15, 2019 4:59 pm

I have just got RIDE 4.1 running on Windows 7 PC connecting to Dyalog 17.0 running on a Raspberry PI 3.

I have saved a "configuration" (Type Connect/TCP) and it connects very easily and quickly.

I have then gone into Preferences/Keyboard and clicked on the tickbox
Also enable Dyalog IME (requires RIDE restart)

and the IME works for that session.

However, every time I connect with that configuration, I still need to activate the Preference options before the IME kicks in.

How can I save my IME preference in my save configuration?

(Also, I don't understand the bit about
requires RIDE restart
?)

Thanks
Ray
PS Im very impressed by RIDE 4.1, just wish I could use it on RPi Zeros and may old model 1's
Ray Cannon
Please excuse any smelling pisstakes.
User avatar
ray
 
Posts: 151
Joined: Wed Feb 24, 2010 12:24 am
Location: Blackwater, Camberley. UK

Re: Dyalog IME and RIDE 4.1

Postby AndyS|Dyalog on Tue Apr 16, 2019 8:01 am

Hi Ray

That's odd .. it should work !
Can you take a look in %APPDATA%/Ride-4.1/prefs.json and see if there's a line in it with

"ime":"1",

on it (or possibly given what you describe, with "ime":"0", on it. It should of course be 1.

If you like RIDE 4.1 then perhaps you should try Ride 4.2 from https://github.com/Dyalog/ride/releases .. it's best to take the one tagged as "Latest Release". Firstly that may sort the problem out, and secondly it's the latest and greatest version of RIDE.

That command about restart merely means that you cannot enable (or disable) the IME in the current RIDE session .. the change is effective next time you start RIDE.

We would have liked to have RIDE work on Pi Zeros and 1s, but unfortunately the underlying CEF code doesn't support them.
User avatar
AndyS|Dyalog
 
Posts: 207
Joined: Tue May 12, 2009 6:06 pm


Return to Installation

Who is online

Users browsing this forum: No registered users and 1 guest