cannot load ws before version 11.0

Learning APL or new to Dyalog? Ask "silly" questions here, without fear...

cannot load ws before version 11.0

Postby hbarkhof on Sat Oct 20, 2018 8:34 am

Hello.
Sorry if this question was already answered before. Could not find it in our forums.

Tried to load the finapl workspace but got an error :
"Cannot load workspaces that are earlier than version 11.0"
when using )load fapliddf.dws

Tried this in version 16 and 17 without any luck. Any hints what I am doing wrong ?


Windows 10.
Apl versions 16 and 17 (Unicode)

Thanks for your time and sorry if this is a dumb question.
hbarkhof
 
Posts: 29
Joined: Mon Apr 09, 2018 8:37 am

Re: cannot load ws before version 11.0

Postby Morten|Dyalog on Sun Oct 21, 2018 7:59 am

Henk,

I presume you downloaded the workspace from http://www.finnapl.fi/texts/fapliddf.zip. I will talk to the FinnAPL folks about saving a newer version of the workspace. On Monday, we'll be able to provide you with a new workspace, unfortunately I don't have a sufficiently old version of APL at home. Meanwhile, you might enjoy this on-line application, which searches not only the FinnAPL, but also the APL2 and Dyalog idiom lists: https://miserver.dyalog.com/Examples/Applications/Idiom_Search.mipage.

A bit of background: Dyalog APL goes to some lengths to load old workspaces, but converting old binary formats requires code which is hard to test, and can lead to strange failures. We decided to draw a line at version 11.0 and we are likely to move that line forward every now and again.

The error message means that the workspace is more than 12 years old. If you have a version of Dyalog APL which is closer to 11.0 yourself, you may be able to )LOAD and )SAVE it in that version, and subsequently )LOAD it in 16 or 17.

Regards,

Morten

P.S. In the future, APL source is likely to be stored in text files, and the problem will slowly fade away.
User avatar
Morten|Dyalog
 
Posts: 324
Joined: Tue Sep 09, 2008 3:52 pm

Re: cannot load ws before version 11.0

Postby hbarkhof on Sun Oct 21, 2018 12:18 pm

Thanks for your answe and time Morten ! Preciated.
hbarkhof
 
Posts: 29
Joined: Mon Apr 09, 2018 8:37 am

Re: cannot load ws before version 11.0

Postby Vince|Dyalog on Mon Oct 22, 2018 7:27 am

Hi Henk,

I will send you a version of this workspace saved by version 14.1 via email from Dyalog Support.

Regards,

Vince
Vince|Dyalog
 
Posts: 288
Joined: Wed Oct 01, 2008 9:39 am

Re: cannot load ws before version 11.0

Postby hbarkhof on Tue Oct 23, 2018 1:20 pm

Thanks Vince. I have received it and it works fine !
hbarkhof
 
Posts: 29
Joined: Mon Apr 09, 2018 8:37 am


Return to New to Dyalog?

Who is online

Users browsing this forum: No registered users and 1 guest