Fedora 18 Keyboard Issues

Installing APL, Sorting out Fonts, Keyboards, etc

Fedora 18 Keyboard Issues

Postby conor_f on Tue Jul 02, 2013 12:27 pm

I'm unable to enter APL characters on my laptop's keyboard as the "windows key" is used by Gnome to overview all active windows... What can I do?
conor_f
 
Posts: 13
Joined: Wed May 29, 2013 7:33 pm

Re: Fedora 18 Keyboard Issues

Postby Vince|Dyalog on Thu Jul 04, 2013 11:58 am

Hi Conor_f,

I've discussed this with my colleagues. Here's what information we have for you so far:

Have a look at this webpage: http://www.ryanlerch.org/blog/alt-click-drag-to-move-windows-no-longer-works-in-fedora-18-gnome-3-8/

Does that help you?

You could also consider changing the "switch layout" key from "Any Win key whilst pressed" to "Left Alt key whilst pressed" and "Right Alt key whilst pressed". Any of the "while pressed" can be considered.

Regards,

Vince
Vince|Dyalog
 
Posts: 125
Joined: Wed Oct 01, 2008 9:39 am

Re: Fedora 18 Keyboard Issues

Postby conor_f on Sat Jul 06, 2013 4:58 pm

Hello Vince,

Unfortunately, none of those options are working. I am trying to find a way to either disable or change Gnome's behaviour with the super/meta key, but it isn't working.

I'll keep searching I suppose!
conor_f
 
Posts: 13
Joined: Wed May 29, 2013 7:33 pm

Re: Fedora 18 Keyboard Issues

Postby conor_f on Sun Jul 07, 2013 5:06 pm

I tried upgrading to Fedora 19, configuring the keyboard, etc, again but it still didn't work. I then decided I'd try out the new Dyalog for Raspberry Pi and it is working perfectly on that :) So no fix, but a solution all the same.
conor_f
 
Posts: 13
Joined: Wed May 29, 2013 7:33 pm

Re: Fedora 18 Keyboard Issues

Postby DanB|Dyalog on Sun Jul 07, 2013 7:56 pm

FYI I installed Dyalog on lUbuntu (not Ubuntu) and the Windows key has no effect there. So no APL chars yet.
I haven't found a solution yet so beware.
DanB|Dyalog
 
Posts: 81
Joined: Tue Sep 09, 2008 8:04 pm

Re: Fedora 18 Keyboard Issues

Postby Geoff|Dyalog on Fri Jul 19, 2013 10:33 am

Experiments with Linux APL keyboard:

I installed Fedora 19 on a Laptop.

Experiment 1: KDE

Worked exactly as expected System Settings | Regional and Language - enable layouts. Add a layout. APL is the first one offered. Select it and select the dyalog variant.

Go to the Advanced tab and choose the layout switching option to be "Any Win key (while pressed)". Choose the Menu key for Compose.

Log out and in again. All works.

Experiment 2: Gnome

This did not work as expected. In fact I didn't get this to work at all. I went through a learning curve using dconf-editor which for those who have seen regedit on Windows will seem familiar. There is a program "gsettings" which is a front end for dconf and which does more sanity checking on the values than dconf. However, for actually seeing what is there then dconf-editor is a better viewer. There are two "keys" that appear to be relevant org|gnome|desktop|input-sources and org|gnome|libgnomekbd|keyboard. The first of these actually seems to make a difference the second does not seem to be honoured by the gnome desktop. Perhaps it is there for some future development.

Using these it is possible to set the gnome desktop to support both "en" and "apl". The language indicator actually shows "dya". However, I could not get any of the "while pressed" layout switching to work. A telling experiment was to run a terminal and enter:
sleep 10 ; setxkbmap -query
Change the language to APL using the little language tool during the 10 sec wait.
rules: evdev
model: pc104
layout: apl,gb,us
variant:dyalog,,
options:compose:menu,grp:win_switch

Where did that "us" come from? I didn't put it there.
It seems that changing the language is doing a complete setxkbmap rather than using the "layout as group" approach that gnome itself introduced in 2007 (ish).

I found no way to get a workable APL keyboard under gnome. In fact it is this problem of not having a latching shift (while pressed) to change layout that means we have to go through the IME approach on Windows.

Experiment 3: Xfce

Applications Menu|Setting|Keyboard choose Layout tab. Turn off the "Use system defaults". APL is not in the list of available layouts.

Now you should have a file:
Code: Select all
~/.config/xfce4/xfconf/xfce-perchannel-xml/keyboard-layout.xml


Change, or introduce lines for XkbLayout, XkbVariant, XkbOptions so that it looks like (with your appropriate base language - probably not "gb"):

Code: Select all
<?xml version="1.0" encoding="UTF-8"?>

<channel name="keyboard-layout" version="1.0">
  <property name="Default" type="empty">
    <property name="XkbDisable" type="bool" value="false"/>
    <property name="XkbLayout" type="string" value="gb,apl"/>
    <property name="XkbVariant" type="string" value=",dyalog"/>
    <property name="XkbOptions" type="string" value="compose:menu,grp:win_switch"/>
  </property>
</channel>


Log out and log in. You should now have a working APL keyboard using the "Win" key as your shift into APL.

Warning: It is incredibly easy to overwrite this file using the Keyboard tool.

Experiment 4: LXDE

I could not find a tool to set Language or Layout options. Also my menus were now cluttered with KDE, Gnome, ... programs so it was hard to tell what was "pure" LXDE. I edited
Code: Select all
/etc/X11/xorg.conf.d/00-keyboard.conf

to look like:

Code: Select all
# Read and parsed by systemd-localed. It's probably wise not to edit this file
# manually too freely.
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "gb,apl"
        Option "XkbVariant" ",dyalog"
        Option "XkbOptions" "compose:menu,grp:win_switch"
EndSection


This is a system wide file and you will need root permissions to change it.

Log out and log in and you will now have a working APL keyboard. Not ideal but if you are the only user of the machine then it is probably adequate.

Conclusion:

Avoid Gnome. Since this is the Fedora default this is a bit of a pain.

For an easy life use KDE.

If you want a cut down, minimalist desktop then XFCE and LXDE are usable options.

To get extra desktops then

sudo yum install @LXDE

seems to work. Substitute KDE, XFCE as appropriate. If you are installing from the DVD then KDE is given as an option during the install.
Geoff|Dyalog
 
Posts: 26
Joined: Wed May 13, 2009 12:36 pm

Re: Fedora 18 Keyboard Issues

Postby conor_f on Mon Jul 29, 2013 9:37 pm

Great news! I switched to i3 window manager recently, and was adamant to get Dyalog to work under it. After a lot of effort, I believe I have found a solution for all window managers and Linux distributions even if the window manager usually binds the super key. You can view the solution on my recently started blog. (Note: Tested under Feodra 19 with i3 window manager)
conor_f
 
Posts: 13
Joined: Wed May 29, 2013 7:33 pm


Return to Installation

Who is online

Users browsing this forum: No registered users and 1 guest